VMS Sync Submittals: Submit Button Not Working
The errors in this article can occur after you click the VMS A vendor management system is a web-based application that aggregates available jobs from multiple companies and is used by recruiters to see what jobs need filling. Submittal The Second Stage of Job application flow. This is when the recruiter sends the Candidate CV to the client, a sort of first introduction. Submit button on an ATS record.
Clicking Submit Throws "cannot GET /canvas/submittals" Error
Perform these checks:
- Check the Dev Tools Developer Tools are used in Chrome to capture errors occuring in Bullhorn. F12 on the keyboard. (F12) Network tab for these calls:
- failed /canvas/submittals
- .../signedrequest?canvas=VMS_Sync_Sandbox Non Production Environments are used by customers to test new features prior to them going live.
- Check Headers or Payload Technical term, not specific to BH4SF, it's a data 'pack' sent between two systems that integrate with each other via API tabs for the Request URL.
Does the URL params contain “_sfdc_canvas_authvalue = user_approval_required”? If so, the issue is a Salesforce user permission.
Resolution
Do the following:
- Go to .
- Select .
- Click Edit Policies.
- Change the permitted users to Admin approved users are pre-authorized.
Clicking Submit Loads Submit to VMS Form and Throws Popup
Clicking Submit may sometimes load the Submit to VMS form for a second before throwing this popup: "You don't have permissions to view application with namespace [VMSSNC] and API API, or Application Programming Interface, is used by customers to create custom career portals or to take advantage of Data Mirror/DataMart. Bullhorn prefers to use REST API. name [VMS_Sync_Sandbox]".
This is a Salesforce user permission issue.
Resolution
- Go to .
- Select .
- Select Manage Profiles and add user types to the list.
- System Admin, Standard User In Salesforce terminology, this is anybody that has login access to an instance. In BH4SF instances, usually the staff of recruiting companies, Standard Platform User, etc.
- Click Save.
Clicking Submit Throws Apex Class Popup
You may receive the following popup after clicking Submit: "You do not have access to the Apex class named “VMSSubmitController”".
This is a Salesforce user permission issue.
Resolution
- Go to .
- Look for Apex Classes containing “VMS”.
- Click .
- Add profiles to the class. Repeat this step for all VMS classes.
"503 Service Unavailable No server is available to handle this request"
There are two reasons you may get this error message.
Cause 1
Your Sync account is suspended.
Resolution 1
Re-link your account.
Cause 2
VMS Submit config is pointing to the Sandbox and your account is in Sync Prod.
Resolution 2
- Go to .
- Click Edit and change configuration to production.
- Click Save.
"No such column CandidateID__c on [Object Name]"
You may encounter this error message when a field required for VMS Submittals is missing from an object. This likely to be the Job A job (vacancy, position, role) is an opening for which a customer's client needs a placement. or Application V2 A BH4SF custom object introduced when new data model ATSv2 was added to the core product object.
Resolution
Ensure that you have added fields to the Job Object and added fields to the Application V2 object.