VMS Sync Submittals: Submit Button Not Working
The errors in this article can occur after you click the VMS Submittal Submit button on an ATS record.
Clicking Submit Throws "cannot GET /canvas/submittals" Error
Perform these checks:
- Check the Dev Tools (F12) Network tab for these calls:
- failed /canvas/submittals
- .../signedrequest?canvas=VMS_Sync_Sandbox
- Check Headers or Payload tabs for the Request URL.
Does the URL params contain “_sfdc_canvas_authvalue = user_approval_required”? If so, the issue is a Salesforce user permission.
Resolution
Do the following:
- Go to .
- Select .
- Click Edit Policies.
- Change the permitted users to “Admin approved users are pre-authorized”.
Clicking Submit Loads Submit to VMS Form and Throws Popup
Clicking Submit may sometimes load the Submit to VMS form for a second before throwing this popup: "You don't have permissions to view application with namespace [VMSSNC] and API name [VMS_Sync_Sandbox]".
This is a Salesforce user permission issue.
Resolution
- Go to .
- Select .
- Select Manage Profiles and add user types to the list.
- System Admin, Standard User, Standard Platform User, etc.
- Click Save.
Clicking Submit Throws Apex Class Popup
You may receive the following popup after clicking Submit: "You do not have access to the Apex class named “VMSSubmitController”".
This is a Salesforce user permission issue.
Resolution
- Go to .
- Look for Apex Classes containing “VMS”.
- Click .
- Add profiles to the class. Repeat this step for all VMS classes.
"503 Service Unavailable No server is available to handle this request"
There are two reasons you may get this error message.
Cause 1
Your Sync account is suspended.
Resolution 1
Re-link your account.
Cause 2
VMS Submit config is pointing to the Sandbox and your account is in Sync Prod.
Resolution 2
- Go to .
- Click Edit and change configuration to production.
- Click Save.