QuickBooks Invoice Errors
If you encounter an error while sending data over to QuickBooks,
will display a red X on the Receivables dashboard.Most errors are due to the imported data missing information, such as an account or item name, or QuickBooks not being configured properly to receive the data. Below are some general troubleshooting tips for resolving common errors.
Determining the Error
Hover over the question mark symbol to display the error message. If you can't see the entire message, click the question mark symbol to open it in a pop-up window.
Troubleshooting Invoice Errors

Cause
This error indicates that the QuickBooks Name is missing from the invoice and happens when the invoice generates before the QuickBooks Name field is completed on either the Company or Department/Billing Contact record associated with the invoice.
Resolution
- Make sure the QuickBooks Name field is completed on either the Company or Department records. If this field is not complete, invoices will continue to generate without the QuickBooks Name.
- Edit the invoice and manually enter in the QuickBooks Name in the QuickBooks Name field.

Cause
This error indicates that the invoice is missing the Item information on an invoice line and happens when the invoice is generated before the account and item information is filled out on the associated placement record.
Resolution
Check the following:
- Make sure the Item fields on the invoice are completed and correct.
- Make sure the Item and Account Name fields in the Accounting Information section of the placement are completed and correct. If these fields are not complete, invoices will continue to generate without the Item information.
- Confirm that the items associated with the placement Bill Item and expenses are listed in QuickBooks.

Cause
This error occurs when account or item information on the invoice doesn't match the account or item information found in QuickBooks.
Resolution
Check the following:
- Confirm that the account and item information are in QuickBooks.
- Make sure the Item fields on the invoice completed and correct.
- Confirm the Item and Account Name fields in the Accounting Information section of the placement are completed and correct.
- Confirm that the items associated with the placement Bill Item and expenses are listed in QuickBooks.

Cause
Any error referencing a field being too long is due to the entered field value being larger than QuickBooks' set character limit for the given field.
Resolution
Edit the values on the listed field to fit within the QuickBooks character limit. See Character Limits for Fields in QuickBooks for more information.

Cause
The class has a child and is also a class on it's own. For example: "TEST:abc" and "abc".
Resolution
Check the classes to find the one that has a child, that is also a class on its own. Once you find them, you can either merge the two classes or disable one of them.