QuickBooks Timesheet Errors

Overview

If you encounter an error while sending an data over to QuickBooks, Bullhorn Back Office will display a on the Timesheet dashboard.

Most errors are often due to either the imported data missing information, such as an account or item name, or QuickBooks not being configured properly to receive the data.

Below are some general troubleshooting tips for resolving common errors.


Determining the Error

You can determine the error by hovering your mouse pointer over the symbol to display the error message.

Clicking the symbol will pull the error message into a popup window so you can view the whole message.  

 


Troubleshooting Timesheet Errors

Error

"A Job/Customer could not be found connected to "", please make sure there is a department with this Integration Name"

Cause

This error indicates that the QuickBooks Name is missing from either the Company or Department/Billing Contact record associated with the timesheet.

Resolution

Make sure the QuickBooks Name field is completed on either the Company or Department records.

  • Company Record


  • Department/Billing Contact Record



Error
  • "There was an error saving a TimeTracking. QuickBooks error message: Billable activities must have a customer:job and service item."
  • "There is an invalid reference to QuickBooks Item Service "XXXXXX" in the TimeTracking. QuickBooks error message: Invalid argument. The specified record does not exist in the list."
  • "There is an invalid reference to QuickBooks entity "XXXXXX" in the TimeTracking. QuickBooks error message: Invalid argument. The specified record does not exist in the list. There was an error when saving a Time Tracking."
  • "There is an invalid reference to QuickBooks entity "XXXXXX" in the TimeTracking. QuickBooks error message: Invalid argument. The specified record does not exist in the list. There was an error when saving a Time Tracking."
Cause

These errors indicate that either the customer or bill item information is missing either in BBO or in QuickBooks.

Resolution
  1. Make sure the QuickBooks Name field is completed on either the Company or Department records.
    • Company record


    • Department record


  2. On the placement record, locate the Accounting Information section and verify or complete the Bill Item and Account Name fields.


  3. On the employee record, confirm that the Timesheet Export Name field is complete.
    • The name must match the name on the employee list in QuickBooks.



  4. Make sure the Bill Item and Account exist in QuickBooks.

Error

"Failed to save the Time Tracking transaction. The employee "XXXXXX XXXXXX" provided in the TimeTrackingAdd request has the checkbox "Use time data to create paychecks" set to the Unknown state."

Cause

When an employee is set up in QuickBooks, the setting Use time data to create paychecks needs to be either enabled or disabled.

Resolution
  1. While logged into QuickBooks, select Employees > Employee Center.



  2. Right click on the employee you wish to edit and choose Edit Employee.



  3. In the window that opens, select the Payroll Info tab
    • This may be labeled "Payroll and Compensation Info" in your version of QuickBooks.

  4. Locate the option Use time data to create paychecks.
    • If you would like to use this option, check the box and select OK.
    • If you do not want to use this option:
      • Check the box and select OK.
      • Edit the employee again.
      • Uncheck the box and select OK.

  5. Resend the timesheet to QuickBooks via the Web Connector.

Error

"There was an error creating the Customer "CustomerName":The string "FieldValue" in the field "FieldName" is too long."

Cause

Any error referencing a field being too long is due to the entered field value being larger than QuickBooks' set character limit for the given field.

Resolution

Edit the values on the listed field to fit within the QuickBooks character limit.